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Take your place in the fast-paced industry with Trinity’s
transformational executive certifications.

AN ALLIANCE LIKE NO OTHER.

MULTIPLE BUSINESS FIRMS

ACROSS THE GLOBE COME

TOGETHER TO CREATE EVERY

SINGLE PROGRAM.

Through our unique global input methodology, the Trinity
experience provides learners with the best-in-class and
real-world experiential learning to prepare them for the
ever-changing industry environment.
Every certification is designed to make learners ready for
the industry.

1. THE TRINITY EAC CONCEPT 1. THE TRINITY EAC CONCEPT

The idea behind this education alliance is to
bring together a network of professional
individuals & firms to utilize their domain
expertise and experiences in creating a
holistic guidance mechanism for learners.

CREATED FOR TH E INDUSTRY BY TH E INDUSTRY



TRINITY EAC COUNTERS TH E PROBLEM 
USING A S IMPLE CONCEPT:

WHY ARE BUSINESSES ALL OVER THE
WORLD SPENDING CAPITAL ON TRAINING ?

Instead of a few being burdened, everyone in the industry can contribute
little time and effort to design and execute a world-class training. Such a
training will result in professionals that match the industry expectations,
as their training comes right from the industry. This mode of operating
exponentially enhances the career prospects of learners.

SIMPLICITY  IN  UNIQUENESS

A PROMINENT 

PROBLEM IN THE 

INDUSTRY

Trinity Education Alliance Council creates domain specific networks, the
aim of which is to design and execute real-world quality training
programs which produces high-octane professionals with the desired
attitude and skills. Such an alliance is unmatched in the industry.

3. TRINITY EAC SOLUTION 3. THE TRINITY EAC SOLUTION

When the industry comes together for training,

learners get a sense of belonging to their future

potential employers/partners.

“ “

Kumod Shirkande
▪ Founder: TRINITY EAC, AI Sciences INC. 

and Slikun Technologies
▪ NASA Citizen Scientist

Formal education fails to
encompass the real-world
domain specific training,
creating the need for
specialized true industry
training. This has given
rise to a host of
professional certifications.

Professionals who usually
contribute to the domain
currently, are the best
people to learn from.
However, such people
cannot be tapped easily
for training due to their
professional commitments.

Professional level training
programs have become all
together a different industry
in themselves, which keep
learners disconnected from
the dynamic requirements of
real-world businesses. This
means that industry does
not get professionals as per
their expected standards.

Such experts, if hired, need
to be paid higher in order
to honor their time
utilization appropriately,
resulting in a higher
program fee. This ultimately
burdens the learners with a
high cost of quality
education.
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Learn what’s right, what’s ‘IN’ right now. Learn
from and learn with professionals who are
currently making their valued contributions to
the domain. Learn without taking any break from
your profession.

Be a part of the education alliance. Join a
community of a huge number of professionals
and businesses. Receive not just updated
information about the field but also create/grow
your own professional network.

Explore the endless possibilities in job prospects,
freelancing work and business alliances. Once a
part of the Trinity alliance, the whole community
can work to get you better opportunities.

Challenge yourself with life-size projects after a
rigorous coursework. Ensure your knowledge
absorption with unlimited projects to practice
under the trainer’s guidance, upto 1 year after
program completes.

Your project performance opens the doors to
your hiring as a freelancer by Trinity EAC alliance
companies. Get paid for showcasing your
superior knowledge and implementation skills.

THE 

TRINITY EAC

ADVANTAGE

WITH

CUTTING-EDGE

TECHNOLOGY

2. THE TRINITY EAC ADVANTAGE

We are committed to honest 

training… 

Nothing more nothing less !!!

“

“

EVERY TRAINING DESIGNED AT TRINITY EAC PROMISES 
THAT:

▪ Learners shall be trained with an updated
curriculum, most recent case studies and
transparent industry insights.

▪ Learners develop the right professional attitude
towards professional career, their domain and the
industry at large.

▪ Learners develop expertise in practically applying
concepts learnt, by working on life-size projects.

2. THE TRINITY EAC ADVANTAGE

Dr. Vishal Ghag
• Program Director, Management - TEAC
• Managing Director - Pratibhashala Foundation
• Director - SLIKUN Institute of Management & 

Technology, Mumbai & 
• Director - Slikun School OF Business, London



Data 
Scienc

e

Data Science
& AI

Investment
Banking

Business
Management

Trinity EAC’s program designers understand the importance of time. For this reason, all programs are conducted part-
time, while you manage your full-time education or job. Additionally, all programs come with an extension period to take 
care of any uncertainties.

P R O G R A M S  O F F E R E D

Certified Professional in Data 
Science and AI

(CP-DSAI)

(3 months)

Executive Post-Graduate in Data 
Science and AI
(EPGP - DSAI)

Masters Program in Data 
Science, AI and Quantum 
Computing
(M - DSAIQ)

Corporate & Group 
Training Programs

(12 months)(8 months) (Customized)

(6 months)

Professional Certification in 

Certified Investment Banking 
Operations Analyst

Masters Program in
Investment Banking

(12 months)

Certified Sales 
Management Associate

Certified Business 
Development 
Professional

Masters Program in 
Business Administration

(15 months)(6 months)(6 months)

M o r e  t o  l a u n c h  s o o n …

4. PROGRAMS OFFERED

Corporate & Group 
Training Programs

Corporate & Group 
Training Programs

(Customized)

(Customized)



The field of Data Science is gaining an exponential importance, thereby
creating a high demand for data scientists and analysts.

Data Science has already become one of the top 3 careers all over the
world and is bound to be the largest in-demand field within the next
decade.

With TEAC’s data science programs, develop the critical skill of creating
advanced techniques for harnessing the power of data.

D ATA  S C I E N C E  T R A I N I N G  P R O G R A M S

Top 3  reason s  fo r  learn i n g  Dat a  Sc i en ce

It is amongst the largest job producing industries in the world.
Exponentially increases your career prospects.

It is beneficial for those who aim to advance their careers as well as
those who wish to restart on a new career path.

Data Analysts can take up a job, work as freelancers or consultants, or
set up their own ventures to create a better professional path for
themselves.

The syllabus of all the programs are the same. Focus changes according to the candidate
and type of training.

Become a  par t  o f  t he  expon en t i a l l y  deve lop i n g  
dat a  i ndus t ry.  

Technical Training 
Partner

Project Training 
Partner

Industry Training 
Partner

*

A company formed with
a vision and dedicated to
taking the field of data
sciences on the next level
in Indian IT industry
using its unique
competencies.
AI Sciences Inc. has
designed the Trinity EAC
training programs using
its expertise to include
the most relevant
concepts to train learners
and fulfill the
expectations of their
future employers in the
domain.

A young brand run by
veteran IT tech experts
works to provide the
industry-best
technology solutions to
its clients. Slikun Tech
Labs provides Trinity
EAC learners its own
projects (live/recent) to
make them understand
the real-world scenarios
and scale of projects in
the field of analytics and
BI and giving them the
confidence to perform
in their future jobs.

A non-profit organization
aimed at providing the
best real-world education
to learners at lesser than
affordable cost, (if not
free) thus making higher
education viable for all.
Pratibhashala Foundation
takes care of entire
student profile building
and management,
facilitating industry
training, helping them
with interview and
network building skills to
complete 360°
development.

M E E T  T H E  F O U N D I N G  PA R T N E R S

AI
AI Sciences Inc.

PS
Pratibhashala

Foundation

SK
Slikun Technologies

AI SCIENCES INC PRATIBHASHALA 
FOUNDATION

SLIKUN TECH LABS

5. TEAC DATA SCIENCES TRAINING

H E R E  I S  W H Y. . .



• Database Management Systems
• SQL development
• Data Warehousing
• Data Mining

• Importance of BI
• 3 top different tools in BI
• Industry & Job Market of BI
• Advanced Excel
• Use of excel for descriptive analytics

• R Programming & Statistics:
• R Programming Basics
• Statistical Concepts for 

Machine Learning (Basics of 
ML)

• Predictive Modeling (ML) with 
R:

• Regression Techniques
• Classification Techniques

• Python Programming:
• Basics of python programming 
• Python Libraries (for Data Science & 

ML)

• Regression Techniques
• Classification Techniques
• Supervised & Unsupervised 

Techniques
• Neural Network, Text Mining & 

Ensemble Methods

• AI, DL & NLP:
• Introduction to AI & Deep 

Learning
• Deep Learning Algorithms
• Application of AI (Computer 

Vision, NLP, AV Data)

• Scientific Programming with 
Julia:

• Basics of Programming in Julia
• Structuring Data and Functions in 

Julia
• Descriptive and Inferential 

Statistics

S Y L L A B U S  &  M O D U L E S G E T  T R A I N E D  O N  A  M E T I C U L O U S LY  D E S I G N E D  S Y L L A B U S

Module 1

D a t a b a s e  
M a n a g e m e n t

Module 2

B u s i n e s s  
I n t e l l i g e n c e

Module 3

R  P r o g r a m m i n g  
&  S t a t i s t i c s

Module 4

M a c h i n e  L e a r n i n g  
u s i n g  R

Module 5

P y t h o n  
P r o g r a m m i n g

Module 6

M a c h i n e  L e a r n i n g  
u s i n g  P y t h o n

Module 7

A I  &  D e e p  
L e a r n i n g

Module 8

P r o g r a m m i n g  
w i t h  J u l i a

5. TEAC DATA SCIENCES TRAINING



6. PROFESSIONAL CERTIFICATION PROGRAM

P R O F E S S I O N A L

C E R T I F I C A T I O N  P R O G R A M

This learning path is ideally designed for
learners:

• Who are new in the field and are unsure
whether data science is the ideal field for
them.

• Who have some industry experience but wish
to make a career switch.

• Those who can afford to or wish to spend less
money until they are sure about the field.

• Who wish to make quickly join the industry
and then develop their own knowledge bank.

About The Program

The entire certification journey is split into 3
levels, classified based on concept complexity
and job opportunities. Individuals can start off
with CDSA and start their professional journey
in the domain. Once they start developing a
real-world understanding of analytics and data
management, they can gradually move on to
higher certifications.

Exam Type:
✓ MCQs: 25 marks
✓ Descriptive: 75 marks
✓ Project: 100 marks

Minimum Passing Percentage: 80%

o PGP-EX plus 
o Artificial Intelligence (AI)
o Deep Learning (DL)
o Natural Language Processing (NLP)
o Scientific Programming with Julia
o Introduction to Quantum 

Computing
o 9 Capstone Projects

o CP-DSAI plus
o R Programming & Statistics
o Predictive Modeling (ML) 

with R
o Python Programming
o Predictive Modeling (ML) 

with Python
o 5 Capstone Projects

Exam Type:
✓ MCQs: 25 marks
✓ Descriptive: 75 marks
✓ Project: 100 marks

Minimum Passing Percentage: 75%

Exam Type:
✓ MCQs: 25 marks
✓ Descriptive: 75 marks
✓ Project: 100 marks

Minimum Passing Percentage: 70%

Exam Details: Exam Details: Exam Details:

Certified Professional in Data 
Science and AI

(CP-DSAI)

o DBMS & SQL
o Data Warehousing
o Data Mining
o Business Intelligence
o Advanced Excel, Tableau
o Introduction to R and ML 

with R
o 3 Capstone Projects

Program Duration:
3 months

Executive PG in Data Science and AI
(EPGP - DSAI)

Masters in Data Science, AI & 
Quantum Computing

(M - DSAIQ)

Modules: 1 & 2

Program Duration:
6-8 months

Modules: 1 to 6

Program Duration:
12 months

Modules: 1 to 8



The PGP learning path is ideally designed for those:
• Industry professionals with more than 2 years of experience

• Fresh Graduates with a background of IT/Comps or programming.

• Working Professionals who do not have the time to go for a Masters degree

• Professionals who wish to acquire both knowledge and PG certification in
data science

The PGP-EX is an 8-month practical

learning intensive program with a

focused case-study based training,

specifically targeted towards

experienced candidates. The program

comes with an inherent 4-month long

extension period to ensure that working

professionals can honor their

professional commitments as well.

This PG equivalent certification program

is designed to help experienced

professionals to understand

the concepts in data science and learn

to apply the same to their businesses,

thus mastering the skills in applied

analytics.

E X E C U T I V E  P O S T - G R A D U A T E P R O G R A M  I N  D A T A  S C I E N C E  &  A I ( E P G P - D S A I )

A  F A S T  P A C E D  
C A S E - S T U D Y
B A S E D  P R O G R A M  
D E S I G N E D  F O R  
E X P E R I E N C E D  
L E A R N E R S

Semester

(1.5 months)

1 Semester

(2 months)

2 Semester

(2.5 months)

3

7. PGPEX PROGRAM DETAILS

PROGRAM DURATION:

6-8 Months

Exam Type:
✓ MCQs: 25 marks
✓ Descriptive: 75 marks
✓ Project: 100 marks

Minimum Passing Percentage: 80%

Exam Details:

o DBMS & SQL
o Data Warehousing
o Data Mining
o Business Intelligence
o Advanced Excel, Tableau
o Introduction to R and ML with 

R
o 3 Capstone Projects

Modules: 1 & 2 Modules: 1 to 6 Modules: 1 to 8

o CP-DSAI plus
o R Programming & Statistics
o Predictive Modeling (ML) with R
o Python Programming
o Predictive Modeling (ML) with 

Python
o 5 Capstone Projects

Exam Type:
✓ MCQs: 25 marks
✓ Descriptive: 75 marks
✓ Project: 100 marks

Minimum Passing Percentage: 75%

Exam Details:

o PGP-EX plus 
o Artificial Intelligence (AI)
o Deep Learning (DL)
o Natural Language Processing (NLP)
o Scientific Programming with Julia
o Introduction to Quantum Computing
o 9 Capstone Projects

Exam Type:
✓ MCQs: 25 marks
✓ Descriptive: 75 marks
✓ Project: 100 marks

Minimum Passing Percentage: 70%

Exam Details:

PROGRAM FEES

For Indian Students

INR 90, 000/-

For International Students

$ 1200.00



ELIGIBILITY:
• Graduate in any discipline or final year of 

graduation
• Less than 2 years of total experience in any industry

M A S T E R S  P R O G R A M I N  D A T A  S C I E N C E ,  A I  A N D  Q U A N T U M  C O M P U T I N G ( M - D S A I Q )

The program designers at Trinity EAC 
understand the problems faces by 
businesses with inexperienced 
candidates and a major amount of 
capital being spent on their orientation 
& training. To resolve this, the Masters 
program involves industry training as 
an intricately woven part of the 
curriculum. Exposing the learners to 
the industry beforehand is the only 
solution.

Semester 1 Semester 2

• Orientation – Introduction 
to the industry and Data 
science

• DBMS & SQL
• Data Warehousing
• Data Mining
• Business Intelligence
• Advanced Excel, Tableau

• Exam – Sem 1
• (Viva, MCQs, Descriptive)

• Industry training
• Internship Project 1

• Exam – Sem 2
• (Project Report, Viva)

Semester 3

• R Programming & 
Statistics

• Predictive Modeling (ML) 
with R

• Python Programming
• Predictive Modeling (ML) 

with Python

• Exam – Sem 3
• (Viva, MCQs, 

Descriptive)

Semester 4

• Industry training
• Internship Project 2

• Exam – Sem 4
• (Project Report, Viva)

Semester 5

• Artificial Intelligence 
(AI)

• Deep Learning (DL)
• Natural Language 

Processing (NLP)
• Scientific Programming 

with Julia

• Exam – Sem 5
• (Viva, MCQs, 

Descriptive)

Semester 6

• Placement training
• Problem solving case 

study 
• Program designing 

Case Study
• Internship Project 3

• Exam – Sem 6
• (Project Report, Viva)

8. MASTERS PROGRAM DETAILS

Blending technical knowhow with industry-
oriented skill building, the resulting 
amalgamation ensures that individuals 
transform themselves into utter 
professionals with the right attitude and 
aptitude. Such individuals can guarantee a 
better throughput since their thinking is 
aligned with the company beforehand. This 
training is unmatched in the industry. 

The industry orientation training takes 
learners on a journey through the real-
industry through live interactions, latest 
technology workshops, interview 
preparations, on-the-job skills, business 
understanding, virtual industry visits, 
internships and a lot more. A holistic 
professional development the prima 
facie outcome of the training.

The Masters program is a very 
specifically designed course for fresh 
graduates, who haven’t yet been 
exposed completely to the industry. 
Freshers need a lot of guidance at the 
start of their careers in order to 
ascertain the do’s and don'ts of the 
industry. A lack of orientation poses a 
big hindrance to their professional 
journey and must be carefully 
handled.

A  U N I Q U E  P R O G R A M  W I T H  A  Y E T  
U N M A T C H E D  O F F E R I N G  S P E C I A L LY  
D E S I G N E D  F O R  F R E S H  G R A D U A T E S

8. MASTERS PROGRAM DETAILS

PROGRAM DURATION:

12 + 3 Months

PROGRAM FEES

For Indian Students

INR 1, 10, 000/-

For International Students

$ 1500.00



Partner up with Trinity EAC for projects and training and open
up a multitude of opportunities for raising your brand equity
in the market.

CORPORATE & I NSTI TUTI ONAL TRAI NI NGS

A completely customizable training solution offered by TEAC
to organizations and educational institutions, aimed at
empowering them with the right tools to upgrade their own
businesses as well as outperform the competitors.

9. CORPORATE / GROUP TRAININGS 9. CORPORATE / GROUP TRAININGS

S t a y A h e a d To S t a y A l i v e…

The world is becoming increasingly more
data-centric and many organizations are
working towards harnessing the power of
data. Because corporates have a huge
pressure of constantly upgrading the
knowledge bank of their employees and
management, Trinity EAC also executes its
Data Science trainings for all corporate
groups. The training modules as well as
certifications can be customized according
to the unique requirement of the group.
TEAC team also guides the groups on real-
life projects that they may be undertaking
in the company. Programs can be
sponsored or self-funded or semi-funded
as per mutual agreement between TEAC
and the sponsor company.

D a t a I s T h e N e x t G e n O i l…

With the requirement for data science
professionals increasing day by day,
education institutions are trying harder
to inculcate Data Science trainings are
collegiate level. To aid their efforts, TEAC
offers customized training solutions to
universities and colleges. The structure,
time period, certification and program
fees can all be tailored as per the needs
of the institutions.
TEAC offers institutions the flexibility to
incorporate external training within their
regular curriculum thereby making
learning more holistic and career-
oriented for students, something which
is quite lacking in the context of formal
education in developing countries.

A  D U A L  P A R T N E R S H I P O F F E R I N G

Owing to the huge network of Data Science Professionals and firms operating
together with us, TEAC offers a unique offering; to be a partner in training as
well as project execution. Both corporate firms as well as education institutions
can now partner with TEAC and take up projects from clients in the field of
DBMS, BI, Data Analytics and more. Our team can either train you or execute
the project on your behalf. TEAC’s expertise and experience can prove
monumental in up-scaling your brand value in the market.



Data, AI & QC Scientist

Kumod Shirkande

• Founder - AI Sciences INC,, Trinity Education Alliance Council and SLIKUN Technologies 

• Technical Head & HOD (Analytics) - Slikun Institute of Management and Technology, Mumbai.

• Quantum Computing Researcher at IBM Qiskit

• Member - International Astronomical Search Collaboration (IASC)

• Researcher - NASA’s Earth and Space Science Project – Sci Starter

+91 99307 22498

Kumod.s@gmail.com

Kalyan, Thane, MH

PROFESSIONAL FIGURES

Students Trained in Analytics: 

1000+

Projects Delivered in Analytics: 

25+

Total Client Count: 

45+

• Analysis of Banking & Finance Applications for – ICICI, HDFC, Yes Bank, SBI, Centrum Wealth and EPS

• Core team member of Digital Server Capacity Planning for SONY DADC in Austria and Germany

• IT Operations & Technology Lead for SONY MUSIC’s Australia, Europe and India Projects

• Core Team Member of Database Architect & Designing Team of Reserve Bank of India

• Currently, M. Tech. in Quantum Computing – IIT Madras

• Masters in Information Management from K. J. Somaiya Institute of Management Studies & Research, Mumbai.

• Bachelor of Engineering in Computer Science from Shivajirao S. Jondhale CoE, University of Mumbai

EDUCATION DETAILS

PROFESSIONAL ACHIEVEMENTS

Founder ’s  Prof i le

KEY HIGHLIGHTS



D E TA I L E D  S Y L L A B U S

Module 1: Database

Introduction To SQL
>  What is SQL?
>  Why SQL?
>  What are relational 
databases?
>  SQL command group
>  MS SQL Server installation
>  Exercises 

SQL Data Types & 
Operators
>  SQL Data Types
>  Filtering Data
>  Arithmetic Operators
>  Comparison operators
>  Logical Operators
>  Exercises 

Useful Operations in SQL
>  Distinct Operation
>  Top N Operation
>  Sorting results
>  Combine results using 
Union
>  Null comparison
>  Alias
>  Exercises 

Aggregating Data in 
SQL
>  Aggregate 
functions
>  Group By clause
>  Having clause
>  Over clause 

Introduction to Database Management 
System
> Database-System Applications
> Purpose of Database Systems
> View of Data
> Database Languages
> Relational Databases
> Database Design
> Data Storage and Querying
> Transaction Management
> Database Architecture
> Data Mining and Information Retrieval 

Introduction to Relational 
Model
> Structure of Relational 
Databases
> Database Schema
> Keys
> Schema Diagrams
> Relational Query 
Languages
> Relational Operations 

Writing Sub-Queries in 
SQL
>  What are sub-queries?
>  Sub-query rules
>  Writing sub-queries
>  Exercises 

Common function in SQL
>  Ranking functions
>  Date & time functions
>  Logical functions
>  String functions
>  Conversion functions
>  Mathematical functions
>  Exercises 

Analytic Functions in SQL
>  What are analytic 
functions?
>  Various analytic functions
>  SQL syntax for analytic 
functions
>  Exercises 

Writing DML Statements
>  What are DML 
Statements?
>  Insert statement
>  Update statement
>  Delete statement
>  Exercises 

Writing DDL Statements
>  What are DDL 
Statements?
>  Create statement
>  Alter statement
>  Drop statement
>  Exercises 

Using Constraints in SQL
>  What are constraints?
>  Not Null Constraint
>  Unique constraint
>  Primary key constraint
>  Foreign key constraint
>  Check constraint
>  Default Constraint
>  Exercises 

SQL Joins
>  What are joins?
>  Cartesian Join
>  Inner Join
>  Left & Right Join
>  Full Join
>  Self Join 

Views in SQL
>  What are views?
>  Create View
>  Drop view
>  Update view 

Introduction to Data 
Warehouse
> Decision-Support Systems
> Data Warehousing
> Components of a Data 
Warehouse
> Data Warehouse Schemas 

Introduction to Data Mining
> Classification
> Decision-Tree Classifiers
> Support Vector Machines
> Regression
> Association Rules
> Other Types of 
Associations
> Clustering
> Other Forms of Data 
Mining
> Data Visualization 

Exercises
Case Studies
Problem Solving



D E T A I L E D  S Y L L A B U S

Module 2: Business Intelligence

Introduction to Business 
Intelligence & Visualization
> What is Business 
Intelligence?
> What is data visualization?
> Need for Visualization
> Uses of visualization 

Introduction to Tableau
> What is Tableau
> Tableau vs. Excel
> Installing Tableau 
Desktop
> Overview of Tableau 
Desktop
> Various Applications of 
Tableau
> Components of Tableau 
Desktop
> Benefits of Tableau and 
Opportunities
> Tableau Products & 
Certifications
> Tableau Architecture
> Saving and publishing 
your work in Tableau 

Dive into Tableau
> Explore Tableau Interface
> Understand various 
Tableau terminologies
> Create Different Views to 
Analyze Data

Connecting Data Sources
> Connection Options
> Data Types
> Data Roles
> Joins & Over Joins
> Unions
> Custom SQL Query
> Data Blending
> Editing Connections
> Case Studies

Tableau Generated Fields
> Use of Measure Names 
and Measure Values
> Compare Multiple 
Measures
> Fetch Number of 
Records In Database
> Latitude & Longitude 
Fields
> Case Study 

Data Manipulation in Tableau
> Creating Groups
> Creating Combined Fields
> Sorting
> Filtering Data
> Sets
> Binning Data
> Hierarchies

Working with Dates in 
Tableau
> Changing Date Levels
> Different Date Parts 
> Custom Dates
> Create Fiscal Dates

Data Customization with 
Calculations
> Calculated Fields
> Arithmetic Calculations
> Date Calculation
> String Calculation
> Logical Calculation
> Type Conversion Calculation
> Table Calculation
> Level of Detail Calculations
> String Calculation

Adding Dynamism to a View with 
Parameters
> Introduction to Parameters
> Create a Parameter
> Explore Parameters
> Use Parameters in Calculations
> Parameters in Reference Lines
> Parameters in Filters
> Make Estimates using 
Parameters

Geographical Analysis & Maps
> Uses of Geographical or Map 
View
> Creating a Map view
> Custom Geocoding
> WMS Maps
> Modify Locations 

Creating Visualizations
> Bar in Bar Chart
> Scatter Plots
> Histogram
> Heat Maps
> Highlighting in Tables
> Motion Charts
> Pie Chart
> Bullet Chart
> Box & Whisker Plot
> KPI Chart
> Market Basket Analysis Chart
> Pareto Chart
> Waterfall Chart
> Best Practice for Selecting 
Chart Type

Adding Statistics to Data
> Reference Lines
> Reference Bands
> Distribution Bands
> Trend Lines
> Forecasting
> Clustering
> Summary Card

Formatting & Annotation
> Add Titles, Captions & Annotations
> Formatting Options
> Formatting Axes, Mark Labels and 
Legends 

Dashboards & Stories
> What are Dashboards?
> Why and How are 
Dashboards Useful?
> Creating an Interactive 
Dashboard
> Adding Actions to a 
Dashboard
> Best Practices for 
Dashboard Design
> What is a Story?
> Creating a Story
> Adding a Background 
Image to a Story
> Case Studies

Exercises
Case Studies
Problem Solving



D E TA I L E D  S Y L L A B U S

Module 3: R Programming & Statistics

Fundamentals of R
> Installation of R & R Studio
> Getting started with R
> Basic & advanced data types in R
> Variable operators in R
> Working with R data frames
> Reading and writing data files to R
> R functions and loops
> Special utility functions
> Merging and sorting data
> Case study on data management using 
R
> Important R Packages to learn
> Practice assignment 

Data visualization in R
> Need for data visualization
> Components of data visualization
> Utility and limitations
> Introduction to grammar of graphics
> Using the ggplot2 package in R to 
create visualizations 

Data preparation and cleaning using 
R
> Needs & methods of data 
preparation
> Handling missing values
> Outlier treatment
> Transforming variables
> Derived variables
> Binning data
> Modifying data with Base R
> Data processing with dplyr
package
> Using SQL in R

Understanding the data using univariate
statistics in R
> Summarizing data, measures of central 
tendency
> Measures of variability, distributions
> Using R to summarize data
> Case study on Univariate statistics using R

Hypothesis testing and ANOVA in R to 
guide decision making
> Introducing statistical inference
> Estimators and confidence intervals
> Central Limit theorem
> Parametric and non-parametric statistical 
tests
> Analysis of variance (ANOVA)
> Conducting statistical tests

Module 4: Machine Learning using R

Correlation and Linear 
regression
> Correlation
> Simple linear regression
> Multiple linear regression
> Model diagnostics and 
validation
> Case study 

2. Logistic regression
> Moving from linear to logistic
> Model assumptions and Odds 
ratio
> Model assessment and gains 
table
> ROC curve and KS statistic
> Case Study 

3.  Techniques of customer 
segmentation
> Need for segmentation
> Criterion of segmentation
> Types of distances
> Hierarchical clustering
> K-means clustering
> Deciding number of clusters
> Case study 

4.  Time series forecasting 
techniques
> Need for forecasting
> What are time series?
> Smoothing techniques
> Time series models
> ARIMA 

5.  Decision trees & Random 
Forests
>  What are decision trees
> Entropy and Gini impurity 
index
> Decision tree algorithms
> CART
> Random Forest
> Case Study 

6. Boosting Machines
> Concept of weak learners
> Introduction to boosting 
algorithms
> Gradient Boosting Machines
> Extreme Gradient Boosting 
(XGBoost)
> Case study 

7. Cross Validation & Parameter 
Tuning
> Model performance measure with 
cross validation
> Parameter tuning with grid & 
randomized grid search 
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D E TA I L E D  S Y L L A B U S

Module 5: Python Programming

Introduction to Machine Learning in Python
> What is machine learning & why is it so 
important?
> Applications of machine learning across 
industries
> Machine Learning methodology
> Machine Learning Toolbox
> Tool of choice- Python: what & why?

Introduction to Python
> Installation of Python framework and packages: 
Anaconda and pip
> Writing/Running python programs using 
Spyder, Command Prompt
> Working with Jupyter Notebooks> Creating 
Python variables: Numeric, string and logical 
operations
> Basic Data containers: Lists, Dictionaries, 
Tuples & sets

Iterative Operations & Functions in Python
> Writing for loops in Python
> List & Dictionary Comprehension
> While loops and conditional blocks
> List/Dictionary comprehensions with loops
> Writing your own functions in Python
> Writing your own classes and functions as class 
objects
> PEP 8 guidelines and best practices in python
> Try Except in Python

Data Summary; Numerical and Visual in 
Python
> Need for data summary
> Summarising numeric data in pandas
> Summarising categorical data
> Group wise summary of mixed data
> Need for visual summary
> Introduction to ggplot & Seaborn
> Visual summary of different data 
combinations

Data Handling in Python using NumPy & 
Pandas
> Introduction to NumPy arrays, functions 
&properties
> Introduction to pandas
> Dataframe functions and properties
> Reading and writing external data
> Manipulating Data Columns 

Exercises
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D E TA I L E D  S Y L L A B U S

Module 6: Machine Learning using Python

Basics of Machine Learning
> Business Problems to Data Problems
> Broad Categories of Business Problems
> Supervised and Unsupervised Machine 
Learning Algorithm
> Drivers of ML algorithms
> Cost Functions
> Brief introduction to Gradient Descent
> Importance of Model Validation
> Methods of Model Validation
> Introduction to Cross Validation and 
Average Error 

Generalized Linear Models in Python
> Linear Regression
> Limitation of simple linear models and need of 
regularization
> Ridge and Lasso Regression (L1 & L2 
Penalties)
> Introduction to Classification with Logistic 
Regression
> Methods of threshold determination and 
performance measures for classification score 
models

Tree Models using Python
> Introduction to decision trees
> Tuning tree size with cross 
validation
> Introduction to bagging algorithm
> Random Forests
> Grid search and randomized grid 
search
> ExtraTrees (Extremely Randomised
Trees)
> Partial Dependence Plots

Boosting Algorithms using Python
> Concept of weak learners
> Introduction to boosting algorithms
> Adaptive Boosting
> Extreme Gradient Boosting (XGBoost)
> Case study
> Home exercise 

Support Vector Machines (SVM) and KNN in 
Python
> Introduction to idea of observation based 
learning
> Distances and Similarities
> K Nearest Neighbors (KNN) for classification
> Introduction to SVM for classification
> Regression with KNN and SVM
> Case study
> Home exercises 

Unsupervised learning in Python
> Need for dimensionality reduction
> Introduction to Principal Component Analysis 
(PCA)
> Difference between PCAs and Latent Factors
> Introduction to Factor Analysis
> Patterns in the data in absence of a target 

> Segmentation with Hierarchical Clustering 
and K-means
> Measure of goodness of clusters
> Limitations of K-means
> Introduction to density based clustering 
(DBSCAN) 

Neural Networks
> Introduction to Neural Networks
> Single layer neural network
> Multiple layer Neural network
> Back propagation Algorithm
> Moment up and decaying learning 
rate in context of gradient descent
> Neural Networks implementation 
in Python 

Text Mining in Python
> Quick Recap of string data functions
> Gathering text data using web 
scraping with url-lib
> Processing raw web data with 
Beautiful Soup
> Interacting with Google search using 
url-lib with custom user agent
> Collecting twitter data with Twitter API
> Introduction to Naive Bayes
> Feature Engineering for text Data
> Feature creation with TFIDF for text 
data

Ensemble Methods in Machine 
Learning
> Making use of multiple ML 
models taken together
> Simple Majority vote and 
weighted majority vote
> Blending
> Stacking

Bokeh
> Introduction to Bokeh charts and 
plotting 

Version Control using Git and Interactive 
Data Products
> Need and Importance of Version 
Control
> Setting up git and github accounts on 
local machine
> Creating and uploading GitHub Repos
> Push and pull requests with GitHub App
> Merging and forking projects
> Examples of static and interactive data 
products 

Exercises
Case Studies
Problem Solving



D E TA I L E D  S Y L L A B U S

Module 7: Artificial Intelligence & Deep Learning

Introduction to AI and Deep Learning
> What is AI?
> How will AI change the world?
> What is Deep Learning?
> Uses of Deep Learning?
> Examples of Deep Learning & AI 

Introduction to parameter optimisation
> Neural Network representation
> Gradient descent with backpropagation for 
a generic feedforward network
> Optimisers in deep learning [SGD, SGD 
with momentum, RMSProp, Adam]
> Understanding difference in optimisers
with implementation in python from scratch 

Getting Started with Tensorflow
> What is a tensor?
> Setting up Tensorflow and the GPU instance
> Understanding computation graph and 
basics of Tensorflow
> Implementing simple perceptron in 
Tensorflow
> Simple linear Regression with Gradient Tape
> Working with Google Collab
> Visualising training with tensor board
> Classification with a deep feedforward
network using base Tensorflow and Gradient 
tape 

Deep Feed Forward & Convolutional 
Neural Networks
> Limitations of simple feed forward 
networks
> How vision works for humans
> Understanding convolutions, 
strides, padding, filters.
> Convolutions for extracting features 
from images
> How receptive fields change in 
sequence of convolution networks
> Pooling for parameter reductions [ 
max , average , sum]
> Implementing CNN with Tensorflow
> Regularizing with dropout
> Learning rate decay and its effects
> Batch normalisation and its effects 

Introduction to Keras
> Basics of Keras
> Getting started with model 
building in keras
> Sequential and Functional API
> Regularisation with dropout and 
batch-normalisation
> L1 and L2 penalties on weights
> Weight initialisation [e.g. xavier]
> Model saving and loading
> Data generators and data loaders 
in keras
> Transfer learning in keras
> Early stopping
> Model checkpoint
> Custom call backs 

Sequence to Sequence models with Recurrent 
Neural Networks, Long-Short Term Memory 
(LSTM) and Gated Recurrent Unit (GRU)
> Introduction to seq2seq problems
> Intro to RNN architecture
> Backpropagation through time and vanishing 
gradient
> Modelling sequences
> Limitations of RNNs and data reshaping for 
RNNs
> Introduction to LSTM
> Univariate times series with LSTM
> Multidimensional time series with LSTM
> Action sequences with LSTM
> Introduction to GRU and implementation on 
text classification 

Unsupervised Deep Learning
> Autoencoders
> Embeddings
> Autoencoders and embeddings
implementation
> Generative Adversarial Networks
> GAN Implementation 

AI Applications: Computer Vision
> Object Detection and Localisation
> Object detection and localisation as 
combination of classification and 
regression problem
> RCNN, fastRCNN and Faster RCNN
> Semantic Segmentation, Mask R-CNN
> YOLO, SSD
> Object detection with pre trained 
models
> Annotating custom data with vott
> Training YOLOv3 for custom data
> Using trained YOLOv3 with a camera
> Face Detection and Recognition
> Face detection with MTCNN
> Face Extraction
> Face embeddings with VGGFace
> Face RecognitionDeep Learning for Natural Language Processing

> Word embeddings
> How to train and use word2vec
> Fasttext
> Glove
> Bi-Directional RNNs
> Encoder Decoder Architecture
> Attention models
> Transformers
> Context Aware word embeddings with BERT
> GPT-2
> QA models with memory network
> Transformer model on SQUAD
> Custom data QnA with cdqa
> Sentence embeddings
> Text Summarisation

Chatbots with Rasa
> Intention and entities
> Rasa installation and project 
setup
> NLU data
> Model pipelines
> Dialogue management
> Dialogue Policies 

AI Applications: 
Working with Audio Data
> Audio data processing in python
> Using spectrogram as features for 
audio data
> Using CNN for audio data
> using 1D CNNs with raw audio data 
Image Captioning And Style Transfer
> Image encoding
> Word embeddings
> Hybrid model
> Mapping output to caption
> Revisiting receptive fields
> Using different layers to learn style
> Understanding loss function for 
style transfer
> Implementation

Exercises
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D E TA I L E D  S Y L L A B U S

Module 8: Scientific Programming with Julia

Introduction to Julia Scientific 
Programming

> Julia version 1.0
> Programming languages and why Julia is 
special
> Getting Ready: Julia programming 
environments
> The Julia REPL - Read, Evaluate and Print 
Loop
> Arithmetical expressions
> Logical expressions
> Julia's Type System
> Variables in Julia
> Functions in Julia
> User-defined functions
> User-defined functions
> Installing Juno using Julia
> Installing Julia Pro
> Practice exercises
> Julia REPL and the notebook
> Arithmetical and logical expressions in 
Julia
> Types and Arrays in Julia
> Julia functions
> Graded Quiz
> What makes Julia special? 

A context for exploring Julia: Working 
with data

> The Ebola Epidemic of 2014
> Loading data using Julia
> Creating .csv from data tables
> For Loops and Date-Time Formats
> Simple plots with the Plots package
> Multiple curves in a single diagram
> How to do a Peer Graded Assignment
> Data and Loops in Julia
> Plots in Julia 

Notebooks as Julia Programs

> Linear Regression Modle in Julia
> Limitation of simple linear models and need of 
regularisation
> Plotting Data and an Approximately Fitted Line 
Simultaneously
> Using the Data - fitting the model parameters
> Practicing fitting a circle to data
> 2 practice exercises
> Making simple models
> Models
> Introduction to Classification with Logistic 
Regression
> Case Studies 

Structuring data and functions in Julia

> Using Julia for descriptive statistics
> Installing packages for this lesson
> Creating simulated data
> Descriptive statistics
> Creating a dataframe
> Descriptive statistics
> Visualizing data
> Inferential statistics
> Exporting data as a csv file
> Package installation and 
troubleshooting in Julia
> Collections
> Functions 



T h a n k   Y o u
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